<p dir="ltr">John, <br>
If your rough idle symptoms persist, it may be a stuck EGR valve, the Idle Air Control (IAC) valve, or a coolant temp sensor (CTS). Cleaning, or replacing the EGR may do the trick. There may be a way to test the IAC and the CTS with a scan tool. Often the parts stores have those to lend out. I'm not sure if the Bluetooth OBD2 testers can perform diagnostic tests, but its worth a shot if you have one. If its none of those things, then it may be a vacuum leak, or worn out plug wires. A vacuum leak can be found by listening for a hiss, and then spraying the area with your throttle body cleaner. If the idle smothes out while you're spraying, then you've found a leak. Just don't spray too much at once. Its highly flammable, and engines are hot. Stay away from the exhaust with it. Vacuum leaks can come from cracked, or disconnected vacuum hoses. Don't mess with the Mass air flow sensor, except as a last resort. They are very sensitive, and often fragile devices.</p>
<p dir="ltr">Because it happens after driving for a while, I'd start with the EGR valve, and the Coolant temp sensor. Some cars have EGRs that just get dirty, and stick open, and cleaning them fixes the problem. Other cars have EGRs with weak solenoids, and need to be replaced. A little research will probably tell you which is more likely for you. </p>
<p dir="ltr">The throttle body cleaning was a good start, and you probably did a good enough job to eliminate it. The butterfly, and the side passages are the most important. If those got cleaned, then you're done there. Dirty plenum walls are relatively unimportant. You may wish to pull the IAT, and clean it, and its passages.</p>
<p dir="ltr">You could also look to see if there is an adjustment procedure for your Throttle Position Sensor.</p>
<p dir="ltr">Bad plug wires can be diagnosed by misting them with water from a spritzer bottle in a darkened garage, or in the evening. If you see little blue sparks, then its time to change wires. Be sure to do them one at a time so that you don't mix them up. If you change wires, do plugs, cap and rotor (if you have them) too.</p>
<p dir="ltr">The last thing that I can think of is dirty fuel injectors that are not atomizing fuel properly. Sadly I don't know of a cheap DIY remedy for that (or diagnosis for that matter). Black smoke (even very faint) from the tailpipe as the car dies would hint at injectors, the IAC, or a faulty coolant temp sensor.</p>
<p dir="ltr">Best of luck. Let us know how it turns out.</p>